Mopar Trucks and Stuff
January 18, 2018, 12:55:19 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: I give up - registration is disabled again.
 
   Home   Help Search Calendar Login Register Chat  
Pages: 1 [2]
  Print  
Author Topic: 84 pace arrow problems  (Read 4372 times)
Leeann
Sr. Member
****
Offline Offline

Posts: 416



View Profile
« Reply #15 on: July 28, 2009, 07:45:41 PM »

Funky - I've never seen an isolator like that one (at least, not that I recognized as an isolator).

Found an install PDF for the Tekonsha:
http://www.pplmotorhomes.com/parts/rv-converters/Battery%20Switch%20871%20RevEpdf2.pdf


Ours is a Progressive Dynamics, looks original to the rig. Seems to work, but we just picked up one of these at a swap meet for $10:


Our existing isolator looks like that without the fins.
« Last Edit: July 28, 2009, 07:49:45 PM by Leeann » Logged

1973 Concord 20' Class A - 440/727
biggdog440
Newbie
*
Offline Offline

Posts: 15


View Profile
« Reply #16 on: July 28, 2009, 09:27:40 PM »

thats what i dont get, it has a blue 3 post similar to that one, then there are 2 more round ones, 1 3 post 1 4 post. Huh
Logged
Leeann
Sr. Member
****
Offline Offline

Posts: 416



View Profile
« Reply #17 on: July 28, 2009, 11:34:00 PM »

Uhhhh...I don't think there should be more than one isolator in the system...
Logged

1973 Concord 20' Class A - 440/727
biggdog440
Newbie
*
Offline Offline

Posts: 15


View Profile
« Reply #18 on: July 29, 2009, 01:30:36 AM »

dont get it, but its all factory Roll Eyes
Logged
Charlie1935
Sr. Member
****
Offline Offline

Posts: 610



View Profile
« Reply #19 on: July 29, 2009, 06:17:21 AM »

Looks like an old Ford starter relay.
Logged
biggdog440
Newbie
*
Offline Offline

Posts: 15


View Profile
« Reply #20 on: July 29, 2009, 07:22:23 PM »

so does the 3 post one behind the batteries! well we went to pull the iso off and we found out there is NO ALT BELT!!!!!!!!! Shocked the pulleys are rusty so hasnt been on there for a while. so going to get parts tomarrow and see what happens. Wink
Logged
Leeann
Sr. Member
****
Offline Offline

Posts: 416



View Profile
« Reply #21 on: July 29, 2009, 07:26:14 PM »

Oh, good god....

That would explain no charging and dead batteries  Roll Eyes
Logged

1973 Concord 20' Class A - 440/727
biggdog440
Newbie
*
Offline Offline

Posts: 15


View Profile
« Reply #22 on: July 29, 2009, 07:41:58 PM »

yeah, i guess it needs one to charge. Grin his dad had it at a shop for awhile and they never fixed it. Huh Roll Eyes
Logged
Leeann
Sr. Member
****
Offline Offline

Posts: 416



View Profile
« Reply #23 on: July 29, 2009, 07:49:26 PM »

yeah, i guess it needs one to charge. Grin his dad had it at a shop for awhile and they never fixed it. Huh Roll Eyes

I hope he didn't pay them anything  Angry
Logged

1973 Concord 20' Class A - 440/727
Pages: 1 [2]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!